PDA

Vollständige Version anzeigen : Mausrad ... !!???!!!!!


ScotlandYard
06.10.2002, 16:51
Hallo zusammen,

ich wünsche einen schönen Sonntagnachmittag!

Ich habe ein Problem, das viele bereits hier im Forum diskutiert haben. Trotz Durchsicht aller Beiträge bin ich mit meiner Datenbank und der Deaktivierung des Mausrades nicht weiter gekommen. Ich verwende Access XP.

Folgendes Problem: Meine Formulare bestehen fast auschließlich aus Haupt- und Unterformular. Auf dem Laptop werden die Formulare fast auschließlich mit Bildlaufleiste dargestellt, so dass das Mausrad das Bild nur nach oben und unten fährt. Auf meinem PC mit 21''-Bildschirm werden die Formulare ganz dargestellt, mit dem Erfolg, dass nun das Mausrad den Datensatz wechselt.

Gibt es denn wirklich keinen einfachen Weg, diese Sch...-Funktion abzustellen? Das kann doch fast nicht sein. Mit den anderen Codes, die so kursieren, kommt es regelmäßig zum Absturz von Access. Das kann doch nicht der Sinn der Sache sein ...

Hat jemand eine einfach Lösung für dieses scheinbar unlösbare Problem gefunden???

Vielen Dank, bis bald,

Scotty

Günther Kramer
06.10.2002, 18:36
Hallo,

hast du schon diesen Tipp versucht?

<a href="http://www.ms-office-wissen.de/askdrmof/details.php?id=45" target="_blank">http://www.ms-office-wissen.de/askdrmof/details.php?id=45</a>

PS: Da war ein Fehler im Code, der jetzt weg ist!

ScotlandYard
07.10.2002, 14:24
Hallo ihr alle,

ich habe mittlerweile eine Lösung für mein Problem gefunden. Microsoft hat auf seiner Homepage ebenfalls einen Verweis auf die Änderung der Datensätz via Mausrad. Hier der Link: <a href="http://support.microsoft.com/default.aspx?scid=kb;EN-US;q278379" target="_blank">Microsoft Access Help</a>
Dieser Code funktioniert wunderbar ...

Wer kein Visual Basic 6.0 auf seinem PC hat, der kann sich den Code (WheelMouse.zip) downloaden auf: <a href="http://www.rogersaccesslibrary.com/misc/misc.htm" target="_blank">http://www.rogersaccesslibrary.com/misc/misc.htm</a>

Was aber nun mein neues Problem ist: ich kann leider jetzt keine MDE-Datei mehr aus meiner Datenbank erstellen. Weiß da jemand Rat?

Dankeschön, liebe Grüße,

Scotty

ScotlandYard
07.10.2002, 16:45
Ich bin´s noch einmal,

ich habe den Fehler selbst gefunden. Es liegt definitiv nicht am MouseWheel-Code. Hatte bei meinem Code einen Fehler, der mir erst in VBA via Debuggen angezeigt wurde. Habe ich die Datenbank in Access über die Schaltfläche Datenbank reparieren und kompilieren gescannt, wurde mir der Fehler nicht angezeigt.
Jedenfalls funktioniert jetzt alles.

Vielen Dank an alle für die bisherige Hilfe in meinen Anfragen,
schönen Abend,

Scotty