PDA

Vollständige Version anzeigen : Leseberechtigung auf MSysObjects


Raller
17.04.2002, 14:59
Tag,

ich möchte die MSysObjects in einer Accessdatenbank lesen (von Excel aus, Grund: Ich möchte wissen, welche Tabellen in der Datenbank sind, Access ist auf dem Zielrechner nicht installiert):

Zuerst setze ich eine "ADODB.Connection"

Dann schicke ich einen SQL-Befehl zur Datenbank:
Select Name FROM [MSysObjects]

Dann kriege ich einen Fehler: "Datensätze können nicht gelesen werden. Keine Leseberechtigung auf 'MSysObjects'"

Alle 'normalen' Tabellen kann ich so lesen und sogar ändern. Kann ich die Lesebestätigung "freigeben"?

Gruß

Raller

Hondo
17.04.2002, 18:33
Hallo,
um die MSys Daten zu lesen musst du sie zuerst sichtbar machen, und dann die Rechte entsprechend legen.
Sollte dann funktionieren.
HTH Andreas

Raller
18.04.2002, 07:08
Hy Andreas,

das habe ich mir gedacht, aber das Wie wäre entscheidend gewesen.
:-(
Danke erstmal, arbeite an einer anderen Lösung.
Gruß
Raller

eddie eagle
04.11.2002, 14:35
Hallo,

hab genau das gleiche Problem. Ich versuche mittels eines Delphiprogramms auf die Tabelle "MSysObjects" einer Access DB zuzugreifen .. leider bekomme ich nur die Fehlermeldung: Keine Leseberechtigung auf "MSysObjects" .. wie kann ich das umgehen und trotzdem, ohne die MDB zu verändern, auf diese Tabelle zugreifen?

Hoffe jemand hat eine Idee.

Raller
04.11.2002, 14:57
Hallo eddie,

ich kann mich zwar nicht mehr genau erinnern, glaube aber folgende Lösung entwickelt zu haben:

1. Die Datenbank ansprechen
2. Die "TableDefs"-Auflistung durchlaufen und die Tabellennamen zurück geben lassen.
Dabei die "MSys" rausfiltern.
Hilft Dir das?
Gruß
Raller

Manuela Kulpa
05.11.2002, 06:14
<font face="Verdana" size="2">Hallo Raller!

Wenn du ADO magst, kommst du auch mit der OpenSchema Methode weiter. Schau dir mal den zweiten weiterführenden Link in diesem Beitrag an:

<a href="http://www.ms-office-forum.net/forum/showthread.php?s=&threadid=62039" target="_blank">VB-Forum - Relations-Attribute, DB-Zugriff über ADO</a>

slg</font>

Nachbrenner
09.03.2005, 00:44
Hallo,
unter Extras >> Sicherheit >> Benutzer- und Gruppenberechtigung muessen für den Administrator alle Checkbox bei der Tabelle MSysObjects ausgewählt sein.

Grueße Stefan

Stef_113
31.05.2007, 21:37
Hallo,
unter Extras >> Sicherheit >> Benutzer- und Gruppenberechtigung muessen für den Administrator alle Checkbox bei der Tabelle MSysObjects ausgewählt sein.


Hallo, ich saß schon die ganze Zeit an dem selben Problem. Habe es haber jetzt eine Lösung im Internet gefunden. Wollt nur sagen, dass das was Nachbrenner gesagt hat funktioniert, wenn man unter Extras >> Optionen >> unter dem Reiter "Ansicht" im Bereich "Anzeige" die Checkbox "Systemobjekte" angekreuzt hat.

Stefan