PDA

Vollständige Version anzeigen : Code blockiert Access


<Rabo>
09.01.2002, 15:43
Habe nach PC-Neuanschaffung (von 533 auf 1GHz) folgendes Problem:
Ich rufe aus einem Formular heraus einen Bericht auf und schließe ihn wieder. Danach ist jede Befehlsschaltfläche und Kombinationsfeld blockiert. Man kann draufklicken aber nix passiert. Wenn man in den Entwurfsmodus wechseln möchte erhält man die Info es werde gerade Code ausgeführt und man könne nicht wechseln. Access kann man nicht mehr schließen (geht nur noch über STRG-ALT-F4). Es läuft im Hintergrund definitiv kein Code ab. Es betrifft aber nicht alle Datenbanken sondern nur 1 und hier auch nur ein einziges Formular!! Ich habe schon versucht das Ganze neu zu erstellen. Kommt aber das gleiche dabei heraus.
Für Hilfe wäre ich echt dankbar.

Ralf

ManfredS
09.01.2002, 17:09
schaut aber trotzdem so aus, als würde da eine endlosschleife laufen.
drücke mal bei so einer blockade strg+pause, falls code läuft, wird er damit angehalten.

<Rabo>
10.01.2002, 10:51
Danke für den Tip.
Hat leider nicht funktioniert.
Würde es einen Unterschied machen ob ich das Ganze mit Makros steuere und nicht mehr in VBA?

Ralf

Alexander Jan Peters
10.01.2002, 11:05
<font face="Tahoma">Hallo Ralf,

nein, VBA ist generell besser als Makros, da z.B eine Fehlerbehandlung möglich ist und die Geschwindigkeit höher ist.
Zu Deinem Problem, etwas mehr Infos wären ganz nett, wie geht denn das Öffnen des Berichts vor sich?

Gruß

A.J. Peters</font>

<Rabo>
10.01.2002, 12:15
So langsam kriege ich die Krise:
Es reicht schon folgendes:
Datenbank aufrufen - direkt ins Datenbankfenster gehen - Irgendeinen xbeliebigen Bericht in Seitenansicht aufrufen - Bericht schließen - Formular aufrufen - Alles blockiert!

Ralf

Thomas Schmitt
10.01.2002, 12:19
Das hatte ich auch mal, da hat nur noch eine alte Version zurückzusichern geholfen.

Ist vielleicht Dein Access defekt, oder die Systemtabellen von Access sind defekt. Irgendein so ein Blödsinn. Gleich zurücksichern.

Grüße vom
Schmitti

MWendel
10.01.2002, 12:23
Probier einmal mal die DB zu reparieren, vielleicht hilft das was?!?

<Rabo>
10.01.2002, 14:46
Erstmal danke für Eure Vorschläge. leider ist keiner dabei mit dem es funktioniert.
Habe die Datei jetzt mal auf einem 2. Rechner getestet. Da tritt der Fehler nicht auf!
Daraufhin den 1. PC mit "format c:" und alles neu installiert - aber der Fehler ist wieder da.

Ralf

Karl-Heinz
10.01.2002, 16:52
hallo,
wenn es bei Berichten passiert, ist auch ein und wenn der richtige Drucker als Standartdrucker installiert, und im Bericht eingestellt?
Karl-Heinz :rolleyes:

Thomas Schmitt
10.01.2002, 17:09
Vielleicht der Druckertreiber???

Grüße vom
Schmitti

<Rabo>
11.01.2002, 10:58
Druckertreiber?
Auch ne Idee, zumal ich mit dem USB-Trieber für den Drucker (Brother HL1440) auch Probleme hatte und wieder auf Parallelbetrieb zurück bin.

Ralf

Aiko
12.11.2002, 12:14
Ich habe wohl das gleiche Problem. Bei mir kommt es aber zum Totalabsturz.

Konnten Sie das Problem lösen. Wenn ja, wäre ich für eine kurze Antwort dankbar auch per Email: APreis@t-online.de