PDA

Vollständige Version anzeigen : /wrkgrp Startparameter auf NT-Rechnern (Verknüpfungsproblem)


Joke
07.01.2002, 12:49
Folgendes Problem:
ich habe auf meinem Rechner (NT 4) eine geschützte Datenbank (Acc97) erstellt. Danach habe ich sie samt einer Kopie der zugrundeliegenden SYSTEM.MDW auf ein Laufwerk des Netzwerkes kopiert. Um den Start der Datenbank möglichst einfach zu machen, habe ich eine Verknüpfung angelegt durch welche ich auch gleichzeitig über /wrkgrp die System.mdw aufrufe.

Hierbei traten schon die ersten Probleme auf. Hier im Forum waren jedoch genügend Hinweise, die sich mit dieser Art des Datenbankaufrufes beschäftigen (Schuld waren fehlende Anführungszeichen). Auf meinem eigenen Rechner klappt jetzt die Übergabe der richtigen System.mdw Datei.

"C:\Programme\Microsoft Office\Office\msaccess.exe" E:\VICDATEN\Lärmdaten\LDB2002.mdb /wrkgrp "I:\VICDATEN\Lärmdaten\VIC_System.mdw"

Wenn ich jedoch auf einem anderen Rechner im Netzwerk die Datenbank mit der gleichen Startverknüpung aufrufe, kommt es zu einer Fehlermeldung. Es erscheint ein Eingabefeld:

Netzwerk Kennwort eingeben
Falsches Kennwort oder unbekannter Benutzername für \\xyz\$C
Verbinden als [______]
Kennwort [_______]

Ich glaube, dass meine Verknüpfung auf anderen Rechnern nicht läuft, weil ich immer noch als Besitzer gelte. Das Laufwerk C im Pfad ist daher das Laufwerk C auf meinem Rechner. Obwohl der Pfad bei allen Kollegen gleich lautet, versucht NT auf meinen Rechner zuzugreifen. Wenn ich den Teil mit dem Verweis auf ACCESS.EXE weglasse, klappt die Übergabe der WRKGRP leider nicht mehr. Ich brauche also immer das C-Laufwerk.

Kann man das irgendwie verhindern? Kann ich eine Verknüpfung machen, die unabhängig vom Rechner ist?

Sascha Trowitzsch
07.01.2002, 13:39
Na, es scheint ja Probleme mit den Laufwerksbuchstaben zu geben.
Ich würde die Pfade nie über Netzlaufwerke angeben, sondern als UNC-Pfad.
( \\server\C\... )

Ciao, Sascha

Joke
07.01.2002, 16:09
Hallo Sascha,

wenn ich den genauen Pfad angeben müsste, so könnte der ja nur zu den C Laufwerken der jeweiligen Teilnehmer führen. Da aber viele auf die Datenbank zugreifen möchten, müsste ich für jeden separat eine Verknüpfung erstellen. Genau das wollte ich mir ja eigentlich ersparen.

In unserer Bude hat jeder PC auf dem C Laufwerk Access lokal installiert. Daher dachte ich, ein allgemeiner Verweis auf das C Laufwerk müsste klappen. Leider ist unter NT C nicht gleich C. Dummerweise hat jede blöde Verknüpfung einen Besitzer anhand dessen das System erkennen kann, welches C Laufwerk gemeint ist. Einen Trost habe ich schon: ein Kollege hat mir mittgeteilt, er habe nur C: bei "Verbinden als" eingetippt. Dann hat alles geklappt. So wie es aussieht, muss jetzt jeder die Verknüpfung auf seinem Desktop ablegen und bei der Kennwortfehlermeldung "C:" eintippen. So wird das C zu "seinem" C. Schön blöd...

Gruß - Heinz