PDA

Vollständige Version anzeigen : ADODB-CLASS IN ACCESS


teoman
02.01.2002, 18:53
ich habe auf einem Windows 2000 Rechner MDAC 2.7 installiert. Ich hatte die Hoffnung gehegt, daß ich dann die ADODB-Class in MS ACCESS 97 benutzen könne. Aber nix wars. Da ich mich mit dem Problem länger beschäftigt habe, hatte ich auf den DL-Seiten von Microsoft auch das "comcheck-tool" gefunden. Mit dem Tool wurde die Registry ausgelesen und hat mir Fehler für Komponenten der Version 2.7 ausgegeben. Lange Erklärung kurze Frage: WIE BEKOMME ICH DIE ADODB-CLASS in ACCESS IMPORTIERT?

Sascha Trowitzsch
02.01.2002, 19:03
Hallo,

Mir ist völlig neu, dass OLEDB auch mit A97 genutzt werden kann.
Die MDAC 2.7 braucht man ohnehin nicht, die enthält nur ein paar Erweiterungen zu neuesten SQL-Server-Features und ASP.
Und der COM-Check gibt wahrscheinlich deshalb Fehler zurück, weil die MDAC ohne etliche DB-Systemdateien, die mit A2000 installiert werden, nicht funktioniert.

Aber vielleicht täusch ich mich ja auch.

Wie hast du denn versucht, die MDAC in Access reinzukriegen. Über Verweise, MS OLE DB Provider?

Und was willst du danach damit anstellen?

Ich denke, in A97 muss man mit ODBCDirekt auskommen.

Grüße von verunsichertem Sascha

A.S.
02.01.2002, 19:19
Hallo Sascha,

bei der Suche nach MDAC im Supportbereich für Acc97 der M$-Corp ergeben sich immerhin 8 Treffer.

Hier der Link (Grmblfx.... Shit M$ :( Der Link den ich gerade hier reingesetzt hatte, funktioniert von extern scheinbar nicht :( )

Es scheint mir zumindest doch wahrscheinlich, das die Möglichkeit besteht OLE DB unter Acc97 zu nutzen. Ich habe es mir jetzt nicht genauer ansehen können, aber vielleicht bringt es Euch ein Stückchen weiter. ;)

PS Nachtrag: Also heißt es <a href="http://www.microsoft.com/germany" target="_blank">http://www.microsoft.com/germany</a> aufrufen, dort in den Support-Bereich für Access. Von da aus weiter nach Access 97 und dort in die Suchmaschine MDAC eingeben. Mit hat die gerade 8 Ergebnisse ausgegeben.

[ 02. Januar 2002: Beitrag editiert von: ArnoSimon ]</p>

Manuela Kulpa
02.01.2002, 19:30
<font face="Verdana" size="2">Hallo teoman

Vorausgesetzt, du hast die Verweise entsprechend gesetzt, solltest du auch ADO in A97 einsetzten können! Hmmm, was funktioniert denn nicht? Es wäre vorteilhaft, diesbezüglich näheres zu erfahren (vielleicht mit ein bissel Code :) )! Ich tippe mal auf die Connection, aber so ohne etwas, ist es schwer zu beurteilen, was es sein könnte!

Mit fragenden Grüßen</font>

Sascha Trowitzsch
02.01.2002, 19:54
Tja, da gibt's doch immer wieder verblüffende Sachen...

(@ Arno: Ich würde immer die englische MSKB nehmen, weil sie mehr Antworten ausgibt. In diesem Fall 18 Treffer ;) )

Also das ist ein Link auf das nötige Vorgehen:

<a href="http://support.microsoft.com/default.aspx?scid=kb;EN-US;Q184233" target="_blank">http://support.microsoft.com/default.aspx?scid=kb;EN-US;Q184233</a>

Wenn teoman es so gemacht hat, wie dort beschrieben, dann kann man sich nur noch Manualas Fragen anschließen...

Ciao, Sascha

teoman
03.01.2002, 10:32
Danke für die Beiträge. Ich habe den Verweis in Access übersehen (Microsoft ActiveX Data Object ....)