PDA

Vollständige Version anzeigen : Zählenwenns


max.70
14.12.2017, 19:49
Hallo Forum,

ich würde gern Eure Hilfe in Anspruch nehmen bei einem Problem mit einer Formel, was ich einfach nicht hinbekomme.
Ich möchte einen Bereich (B5:B11) nach Werten abfragen die zwischen -15 und -10 weiterhin zwischen 10 und 15 sind. Das versuche ich mit ZÄHLENWENNS, dass funktioniert auch für immer einen Suchbereich, aber leider nicht mit allen beiden in einer Formel. Was mache ich hier falsch?
Zum besseren Verständnis habe ich eine Bsp Datei im Anhang.

Danke und MfG Max

lupo1
14.12.2017, 19:53
=SUMMENPRODUKT(N(ABS(ABS(B5:B11)-12,5)<2,5)) für "zwischen"

=SUMMENPRODUKT(N(ABS(ABS(B5:B11)-12,5)<=2,5)) für "genannte Grenzen inklusive"

=SUMMENPRODUKT(N(ABS(ABS(B5:B11)-12,49)<=2,5)) für -10 bis -14,99 und +10 bis +14,99

=SUMMENPRODUKT(N(ABS(ABS(B5:B11+1%%)-12,5)<2,5)) für korrekte Intervalle von -15 bis -10,01 und +10 bis +14,99

max.70
14.12.2017, 20:36
Hallo lupo,

danke für die Hilfe es funktioniert.
Ivh verstehe die Formel zwar nicht, aber es funktioniert. :)

Danke LG Max

lupo1
14.12.2017, 20:44
Die Normierung von Intervallen um Null wird hier auf meiner Seite http://xxcl.de/0058.htm erklärt. Dort fehlt jedoch das doppelte ABS, welches ein weiteres Intervall hinzunimmt und beide normiert.

Somit muss B5:B11 statt viermal nur einmal aufgeführt werden.