PDA

Vollständige Version anzeigen : Fehlender Backslash in Beiträgen


Günther Kramer
04.12.2016, 14:29
Hallo Zusammen,

Ende November 2016 wurde ein Sicherheitsupdate vom Webhoster eingespielt. Seitdem wird in Beiträgen der Backslash verschluckt.
Wir sind zusammen mit 1&1 an einer Lösung dran. Am 07.12.2016 und 08.12.2016 wird das Betriebssystem auf Debian 8 „Jessie“ umgestellt. In diesem Zuge werden auch die MySQL-Datenbanken auf die Version 5.5 umgestellt.
Wir müssen prüfen, ob das Problem damit behoben ist und nicht weitere Probleme auftreten. Notfalls müssen wir über eine neue Version nachdenken oder aber auch über einen Umzug zu einem Hoster. Das alles muss natürlich zuvor getestet werden und geht nicht sofort.

Lösung bis dahin: Statt einem Backslash bitte den Backslash 2x nacheinander schreiben, damit bleibt ein Backslash stehen.

Arne Dieckmann
13.12.2016, 19:38
Ich wiederhole meine Vermutung, dass es sich um ein PHP-Update handelte, bei dem die Einstellung magic_quotes verschwunden ist (weil vollständig aus PHP ab Version 5.4 entfernt). Da wird ein Update des Linux und auch MySQL sehr wahrscheinlich nicht viel bringen.
Ein möglicher Fix für das Backslash-Problem wird unter http://justinklemm.com/fix-replicate-magic-quotes-register-globals-php-5-4/ gezeigt.

Günther Kramer
16.12.2016, 12:47
Hallo Arne,
ich bin immer noch auf der Suche nach dem Fehler und einer Lösung. Auch über einen Wechsel zu einem anderen Hoster oder über das Update auf eine aktuelle vBulletin-Version ist angedacht, da der Umstiegt auf xenforo bis jetzt nicht geklappt hat.
Wir haben keine PHP-Version 5.4 - wir sind immer noch auf 5.2.

Arne Dieckmann
17.12.2016, 09:18
OK. Dank des phpinfos, was du mir zur Verfügung gestellt hast, könnte man evtl. noch schrittweise per php.ini (oder .htaccess)

magic_quotes_runtime
magic_quotes_sybase

auf on setzen.