PDA

Vollständige Version anzeigen : Zählenwenn ungleich null?


Christian#11
10.02.2006, 17:19
Hallo,

ich würde gerne aus einer Spalte mit Zahlen die Anzahl bestimmen von Zahlen die ungleich null sind.

Mit Zählenwenn geht das irgendwie nicht, da er keine Formel als Suchkriterium zulässt. Gibt es einen anderen Befehll mit dem ich die Anzahl <>0 bestimmen lassen kann?

Gruß und Danke Christian

jinx
10.02.2006, 17:28
<font size="2" face="Century Gothic">Moin, Christian,
<table><tr style="vertical-align:top; text-align:center; "><tr><td>Tabelle1</td></tr><tr><td><table border=1 cellspacing=0 cellpadding=0 style="font-family:Arial,Arial; font-size:10pt; padding-left:2pt; padding-right:2pt; "> <style type = "text/css"> th {font-weight:normal} </style> <colgroup><col width=30 style="font-weight:bold; "><col width=79.999998 ></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td>&nbsp;</td><td>A</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >1</td><td style="text-align:right; ">0</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >2</td><td style="text-align:right; ">5</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >3</td><td style="text-align:right; ">0</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >4</td><td style="text-align:right; ">2</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >5</td><td style="text-align:right; ">0</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >6</td><td style="text-align:right; ">6</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >7</td><td style="text-align:right; ">0</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >8</td><td style="text-align:right; ">4</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >9</td><td style="text-align:right; ">0</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >10</td><td style="text-align:right; ">5</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >11</td><td style="text-align:right; ">5</td></tr></table><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#FFFCF9; "><tr><td><b>Formeln der Tabelle</b></td></tr><tr><td><table style="font-family:Arial; font-size:10pt;">A11 : =Z&Auml;HLENWENN(A1:A10;"&gt;0")<br></table></td></tr></table></td></tr><tr><td>&nbsp;</td></tr></tr></table> </font>

raiho
11.02.2006, 12:26
hallo christian,

bei der zählenwenn musst du die bedingung unter anführungszeichen setzen. dann kannst du
zählenwenn(bereich;"<>0")
verwenden

Jolie B.
01.09.2010, 08:19
Hallo,

ich hoffe, dass das hier noch jemand liest nach 4 Jahren..

Ich habe das gleiche Problem, ich möchte die Zellen zählen, die ungleich 0 sind. Das Problem ist, dass diese Zellen aus mehreren Bereichen kommen (um genau zu sein sehr vielen Bereichen). Meine Formel sieht bisher so aus:

=ZÄHLENWENN(AF31; Y31; R31; K31; D31; AA25; T25; M25; F25; AD19; W19; P19; I19; B19; Y13; R13; K13; D13; AB7; U7; N7; "<>0")

Excel findet hier nun einen Fehler, ich nicht. Was ist falsch bzw warum funktioniert es nicht?

Würde mich über Hilfe sehr freuen!

lg
Jolie B.

Backowe
01.09.2010, 09:04
Hi,

probiere es mal so:

=SUMME(ZÄHLENWENN(INDIREKT({"AF31"."Y31"."R31"."K31"."D31"."AA25"."T25"."M25"."F25"."AD19"."W19"."P19"."I19"."B19"."Y13"."R13"."K13"."D13"."AB7"."U7"."N7"});"<>0"))

chris-kaiser
01.09.2010, 10:19
hi

=SUMME(WENN(N(INDIREKT({"AF31";"Y31";"R31";"K31";"D31";"AA25";"T25";"M25";"F25";"AD19";"W19";"P19";"I19";"B19";"Y13";"R13";"K13";"D13";"AB7";"U7";"N7"}))<>0;1))

Jolie B.
01.09.2010, 10:35
Hey, vielen Dank für die Antworten!

Funktionieren beide wunderbar. :)