PDA

Vollständige Version anzeigen : Summewenn - sehr kleine Zahl anstelle 0 ??


Fela
04.02.2006, 16:20
Hallo Leute

Folgende Funktion:
Spalte D: D1=Summewenn(A:A,"="&B1;C:C) , etc

mit
A: String (Namen), 460 verschiedene Einträge in 3600 Zeilen, alphabetisch sortiert
B: B1=Wenn(A1=A2;0;A1), etc
C: Zahlen mit 2 Nachkommastellen

Die Funktion tut soweit das, was sie soll (eine Art Kontostand für jeden Namen erzeugen), aber liefert mir zweimal einen Wert x*e^-14 zurück. Eigentlich müsste dort aber 0 zurückgeliefert werden.

Das ist soweit nicht problematisch, da die zwei Werte natürlich manuell korrigiert werden können (ich brauche nur die Werte), man fragt sich dann allerdigns schon, was bitteschön Excel da tut. Wie können bitte bei der reinen Addition von Zahlen mit 2 Nachkommastellen 14 Nachkommastellen auftreten?

Gruss
Sascha

Beverly
04.02.2006, 17:57
Hi Fela,

die Formatierung der Zelle auf 2 Nachkommastellen ist halt nur eine Formatierung für die Anzeige und hat nichts mit der eigentlichen Zahl die in der Zelle steht zu tun, Excel rechnet intern immer mit viel mehr Stellen. Das kannst du nur umgehen, wenn du die Zahl selbst auf 2 Kommastellen rundest

=RUNDEN(Deine_Zelle;2))