PDA

Vollständige Version anzeigen : Mittelwert etwas schlauer auswerten


Helle67
01.02.2006, 10:12
Hallo, ich habe eine Tabelle :entsetzt: in der ich in Spalte A die Datumsangaben habe.
Nun möchte ich verschiedene Auswertungen z.B. in den Spalten B- E vornehmen.
Wie kann ich mir die Arbeit erleichtern wenn der Monat Februar von A47:A74 geht und ich nicht immer in den Spalten z. B. (MITTELWERT B47:B74) oder sowas eingeben möchte =WENN(G47="";"";MITTELWERT(G47:G74)).
Mir geht es einfach nur um eine Erleichterung und hoffe auf einen Tipp. Ich hoffe es ist verständlich...
Besten Dank

olisch
01.02.2006, 11:57
Ich hoffe es ist verständlich...

Für mich nicht :(

Vielleicht könntest Du mal eine Beispiel-Tabelle hochladen

Gruß Oliver

myfake
01.02.2006, 14:53
Hallo Helle67,

mal schauen, ob Dir das weiterhilft.

Bsp.
<P><blockquote><table border=3 cellpadding=1><tr><td>&nbsp;</td><td align=center bgcolor=#C0C0C0>A</td><td align=center bgcolor=#C0C0C0>B</td><td align=center bgcolor=#C0C0C0>C</td><td align=center bgcolor=#C0C0C0>D</td></tr><tr><td align=center bgcolor=#C0C0C0>1</td><td>&nbsp;</td><td align=center>Wert</td><td align=center>Start</td><td align=center>Ende</td></tr><tr><td align=center bgcolor=#C0C0C0>2</td><td>11.02.2003</td><td align=center>100</td><td align=center>01.01.2004</td><td align=center>31.12.2004</td></tr><tr><td align=center bgcolor=#C0C0C0>3</td><td>12.05.2003</td><td align=center>110</td><td>&nbsp;</td><td>&nbsp;</td></tr><tr><td align=center bgcolor=#C0C0C0>4</td><td>21.03.2004</td><td align=center>50</td><td align=center>Mittelwert</td><td align=center>&nbsp;</td></tr><tr><td align=center bgcolor=#C0C0C0>5</td><td>22.06.2004</td><td align=center>60</td><td align=center>44,33333333</td><td>&nbsp;</td></tr><tr><td align=center bgcolor=#C0C0C0>6</td><td>23.06.2004</td><td align=center>23</td><td>&nbsp;</td><td>&nbsp;</td></tr><tr><td align=center bgcolor=#C0C0C0>7</td><td>20.01.2005</td><td align=center>223</td><td>&nbsp;</td><td>&nbsp;</td></tr><tr><td align=center bgcolor=#C0C0C0>8</td><td>22.02.2005</td><td align=center>17</td><td>&nbsp;</td><td>&nbsp;</td></tr></td></tr></table></blockquote></P><br>
Formel in C5: =SUMMENPRODUKT((A2:A8>C2)*(A2:A8<=D2)*(B2:B8))/SUMMENPRODUKT((A2:A8>=C2)*(A2:A8<=D2))

Über die Zellen C2 und D2 legst Du die zu untersuchende (Zeit-)Spanne fest.

cu
myfake

Helle67
02.02.2006, 17:24
Besten Dank!! Das ist es.
Super die Hilfe, auch wenn es manchmal nicht so einfach ist das Prob zu beschreiben