PDA

Vollständige Version anzeigen : String teilen


alesenk
07.11.2005, 17:36
hallo ich habe folgendes problem: ich habe einen string der folgendermaßen aufgebaut ist: text1/fester text/text2/text3 text1, text2 und text3 haben eine variable länge und heißen immer anders. fester text ist immer gleich. was ich jetzt brauche ist folgende ausgabe: text1/fester text/text2 also alles außer text 3. die ausgabe soll in einer anderen zelle erfolgen. ob mit formel oder mit vba ist mir egal. schon mal vielen dank für die hilfe!!!

Woody
07.11.2005, 17:40
Abend alesenk,

schon mal =A1&B1&C1 analog für =text1&fester text&text2 probiert zum Verketten?

alesenk
07.11.2005, 18:03
schon mal danke für die schnelle antwort. habs aber leider noch nicht ganz verstanden. hab jetzt nochmal ein konkretes beispiel:
spalte1 so ist es und spalte 2 so soll es sein

A (Spalte1) | B (Spalte2)
________________________________________|________________________
Zeile 1| Textilien/Gesamt/Hosen/Shorts | Textilien/Gesamt/Hosen
Zeile 2| Textilien/Gesamt/Hosen/Jeanshosen | Textilien/Gesamt/Hosen
Zeile 3| Möbel/Gesamt/Tische/Holz | Möbel/Gesamt/Tische
Zeile 4| Möbel/Gesamt/Tische/Metall | Möbel/Gesamt/Tische
Zeile 5| Möbel/Gesamt/Stühle/Holz | Möbel/Gesamt/Stühle
Zeile 6| Möbel/Gesamt/Stühle/Metall | Möbel/Gesamt/Stühle

Woody
07.11.2005, 18:12
Hallo alesenk,

habe leider nur ein Hilfskonstrukt mit einer Hilfsspalte in Spalte C.

Gebe B1 =LINKS(A1;LÄNGE(A1)-C1) ein und
in C1 =VERGLEICH("/";LINKS(RECHTS(A1;SPALTE(1:1));1);0), wobei Du nach der Eingabe die Zelle C1 kein Ergebnis liefert. Markiere sie, Drücke F2 und drücke anschließend Strg+Shift+Enter um die Arrayformel ({} Klammern werden gesetzt dabei) abzuschließen. Die Arrayformel kopierst du durch runterziehen.

alesenk
07.11.2005, 18:24
bin mit der antwort zufrieden. schließlich geht es nicht um schönheit sondern darum, dass das ziel erreicht wird. vielen dank

alesenk
08.11.2005, 12:38
wie funktioniert das ganze wenn noch ein wert bei einigen hinzukommt also:

A (Spalte1) | B (Spalte2)
________________________________________|________________________
Zeile 1| Textilien/Gesamt/Hosen/Shorts/kurz | Textilien/Gesamt/Hosen
Zeile 2| Textilien/Gesamt/Hosen/Jeanshosen | Textilien/Gesamt/Hosen
Zeile 3| Möbel/Gesamt/Tische/Holz | Möbel/Gesamt/Tische
Zeile 4| Möbel/Gesamt/Tische/Metall/rund | Möbel/Gesamt/Tische
Zeile 5| Möbel/Gesamt/Tische/Metall/eckig | Möbel/Gesamt/Tische

Woody
08.11.2005, 13:05
Hallo alesenk,

ein Gruß zum Anfang und zum Ende eines Beitrages sehen doch gleich viel freundlicher aus, findest du nicht auch? Schließlich sitzen am anderen Ende des Bildschirms keine Maschinen und soviel Zeit muss sein!

Ich würde die Formel oben quasi nochmal über den ersten Extrakt drüberlaufen lassen. Dann hast du zwei Ergebnisspalten bzw. Zwischenergebnisspalten. Mit einer WENN Formel würde ich dann in Abhängigkeit der Anzahl der "/" Zeichen (3 oder 4) dann das jeweilige Zwischenergebnis in eine finale Ergebnisspalte anzeigen lassen.

Die Formel zum Ermitteln der Anzahl der "/" Zeichen lautet so:
=LÄNGE(A1)-LÄNGE(WECHSELN(A1;"/";""))