PDA

Vollständige Version anzeigen : ADO, provider, Installation


Andre N.
13.06.2004, 10:25
Hallo,

ich arbeite mit Vb6 und Access 2000. Habe eine Datenbankapplikation mit ADO-Zugriff programmiert. Bei der Installation auf dem Zielrechner meldet der PC, daß er den Provider Microsoft.Jet.OLEDB 3.51 nicht finden könne. Was habe ich falsch gemacht?

Sascha Trowitzsch
13.06.2004, 11:46
Ohne Aussage darüber, wie deine Installation aussieht bzw. welche Komponenten du ins Setup mit verpackst, ist es schwer zu raten...

Ich weiß jetzt auch nicht auswendig, in welchen MDAC-Setups - die wohl in deinem Setup enthalten sein sollten - der 3.51-Provider drin ist.
Aber wenn du wirklich mit einer A2000-DB arbeitest, dann sollte eigetlich der 4.0-Provider verwendet werden, denn der 3.51er ist für A97er-Datenbanken.
Da solltest du zunächst deinen VB-Code umstellen und die Connections bzw. Provider-Strings auf "Provider=Microsoft.Jet.OLEDB.4.0" stellen.

Ciao, Sascha