MS-Office-Forum
Google
   

Zurück   MS-Office-Forum > Microsoft Office > Microsoft Excel
Registrieren Forum Hilfe Alle Foren als gelesen markieren

Banner und Co.

Antworten
Ads Der Renner, 11 Entwicklertools für Access, Tipps & Trick und offene Datenbanken zum einzigartigen Preis.
Themen-Optionen Ansicht
Alt 03.01.2018, 11:01   #1
Tomatensuppe
Neuer Benutzer
Neuer Benutzer
Standard Excel2010 - Überlappende Zeit

Hallo,

ich habe eine Datei (hängt an), in der an verschiedenen Datums Zeiten enthalten sind, die sich teilweise überlappen.

Ich bräuchte jetzt eine Formel die mir 1. sagt wie viele Überlappungen es am Tag gibt (vielleicht wenn Überlappung dann 1 sonst 0 dann kann ich weiterarbeiten...)und 2. wie lange die Überlappung dauert.
Am besten in zwei Schritten.

Im Beispiel wäre das am Datum 01.02.2017 2 Überlappungen und 9 Minuten Überlappung.

Weiß jemand hier eine Möglichkeit?
Angehängte Dateien
Dateityp: xlsx Beispieldatei überlappende Zeit.xlsx (8,1 KB, 13x aufgerufen)
Tomatensuppe ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 03.01.2018, 12:05   #2
R J
MOF Meister
MOF Meister
Standard

Hi,

in D3: =WENN(B3 < C2;"Überlappung";"")


In E3: =WENN(D3="";"";C2-B3)

Diese beiden nach unten kopieren und
nur in F2: =ZÄHLENWENNS(D: D;"Überlappung";A:A;A2)

in F3: =WENN(A2=A3;"";ZÄHLENWENNS(D: D;"Überlappung";A:A;A3)) ...und nach unten kopieren...

__________________

Ciao, Ralf

Auf, zum Markplatz der Ideen!
Der sicherste Ansatz für einen Irrtum ist der Glaube, alles im Griff zu haben.
Nur, weil ich den Recorder bedienen kann, macht mich das noch lange nicht zum Musiker.



Geändert von R J (03.01.2018 um 12:17 Uhr).
R J ist gerade online  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 03.01.2018, 12:11   #3
lupo1
MOF Koryphäe
MOF Koryphäe
Standard

Das geht aber nur unter 2 Prämissen:

1) die Daten sind sortiert (anzunehmen)
2) max. eine Überlappung pro Zeile möglich (das könnte auch mehr sein)

9-15
12-16
13-20
14-23 sind 6 Überlappungen

__________________

MfG Lupo - und ein Hallo ebenfalls!
lupo1 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 03.01.2018, 12:13   #4
Drogist
MOF User
MOF User
Standard

Moin,
ich zähle nur 1 Überlappung ...
In D3: =WENN(B3 *
und in D6: ANZAHL(D2:D5)*

__________________

Internette Grüße
Drogist

(Gut) Gefunden bei Storax: "This isn't a code writing service, you need to do some research and have a go at writing some of your own code."
Ich verwende Excel 2016.Wenn du keine Angaben über deine Version gemacht hast gehe ich davon aus, dass auch du mindestens diese Version hast.
Drogist ist gerade online  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 03.01.2018, 12:20   #5
R J
MOF Meister
MOF Meister
Standard

Zitat:

9-15
12-16
13-20
14-23 sind 6 Überlappungen

6 in Minuten, aber Überlappungen (netto) sind es nur 3. Was ist gewollt?

__________________

Ciao, Ralf

Auf, zum Markplatz der Ideen!
Der sicherste Ansatz für einen Irrtum ist der Glaube, alles im Griff zu haben.
Nur, weil ich den Recorder bedienen kann, macht mich das noch lange nicht zum Musiker.


R J ist gerade online  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 03.01.2018, 13:46   #6
Tomatensuppe
Threadstarter Threadstarter
Neuer Benutzer
Neuer Benutzer
Standard

Danke ihr lieben! [D3: =WENN(B3 < C2;"Überlappung] gibt mir meistens auch eine Überlappung beim Datumswechsel. Habe das Datum noch mit =WENN((A2=A3)*usw eingebaut und Zählenwenn +1 addiert. Manchmal sollte man auch einfach denken. Ich hatte eine komplizierte Matrix im Kopf...
Tomatensuppe ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Ads
Antworten


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Besucher: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge anzufügen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

vB Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist An.
Gehe zu


Alle Zeitangaben in WEZ +1. Es ist jetzt 23:09 Uhr.


Partner und Co.
Access-Paradies -Alles rund um die Datenbank Microsoft Access -Code -Programme-Tools -Tipps   Kostenlose Tipps & Tricks, Downloads und Programme   www.kulpa-online.com - Tipps - Tricks - Tutorials - Meinungen - Downloads uvm...   vb@rchiv · Willkommen in der Welt der VB Programmierung   Access-Garhammer - Hier finden Sie jede Menge Beispiel-Datenbanken zu Access und mehr ...   mcseboard.de   Die Top Seite für Excel-VBA-Makros uvm.

Powered by: vBulletin Version 3.6.2 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.

Copyright ©2000-2010 MS-Office-Forum. Alle Rechte vorbehalten.
Copyright ©Design: Manuela Kulpa ©Rechte: Günther Kramer
Eine Verwendung der Inhalte in anderen Publikationen, auch auszugsweise,
ist ohne ausdrückliche Zustimmung der Autoren nicht gestattet.
Beachten Sie bitte auch unsere Nutzungsbedingungen.